lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-4263) remove conflicting versions of the same jar dependencies
Date Fri, 27 Jul 2012 11:41:34 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-4263?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13423818#comment-13423818
] 

Uwe Schindler commented on LUCENE-4263:
---------------------------------------

servlet-api is special and should be handled. servlet-api-3.0 is needed as runtime lib for
jetty. But for compiling solr we should use servlet-api-2.4 (see previous discussions). I
am not sure if this is correctly implemented in Solr, but we should do this, otherwise we
might add method calls to servlet API in SolrDispatchFilter that breaks running the WAR file
with JBoss,...
                
> remove conflicting versions of the same jar dependencies
> --------------------------------------------------------
>
>                 Key: LUCENE-4263
>                 URL: https://issues.apache.org/jira/browse/LUCENE-4263
>             Project: Lucene - Core
>          Issue Type: Sub-task
>            Reporter: Robert Muir
>         Attachments: LUCENE-4263.patch
>
>
> There are 3 instances of this in our build:
> asm-3.1.jar
> asm-debug-all-4.0.jar
> commons-compress-1.2.jar
> commons-compress-1.3.jar
> servlet-api-2.4.jar
> servlet-api-3.0.jar

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message