lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Miller (JIRA)" <>
Subject [jira] [Commented] (SOLR-3613) Namespace Solr's JAVA OPTIONS
Date Thu, 12 Jul 2012 23:26:34 GMT


Mark Miller commented on SOLR-3613:

bq. I'd prefer {{zkRun}} to be {{solr.localZkRun}} to distinguish that this starts a *local*
Zk as opposed to the remote one in {{zkHost}}. 

-0 - I like zkRun as it's short and sweet - your are running zk, or you are not and connecting
to an external zk. I wouldn't fight very hard though. Yonik named it, I'll defer to you guys.

bq. Also, the prop {{zkHost}} is misleading, in that it takes a list of host:port; perhaps
{{solr.zkServers}} is more clear?

The zk guys call it a "connectString". I like zkHost because it's short, works fine with a
single host url, and easily docable about using more, but again, not something I'm going to
fight hard for.

Personally, I liked the brevity of something like java -DzkRun -DzkHost start.jar and how
that works for examples as compared to what we are getting to now: java -Dsolr.zkServers -Dsolr.localRunZk

Just starts to get dense fast.

I also think doc is perfectly sufficient on top of the current names.

> Namespace Solr's JAVA OPTIONS
> -----------------------------
>                 Key: SOLR-3613
>                 URL:
>             Project: Solr
>          Issue Type: Improvement
>    Affects Versions: 4.0-ALPHA
>            Reporter: Jan H√łydahl
>             Fix For: 4.0
> Solr being a web-app, should play nicely in a setting where users deploy it on a shared
> To this regard Solr's JAVA_OPTS should be properly name spaced, both to avoid name clashes
and for clarity when reading your appserver startup script. We currently do that with most:
{{solr.solr.home,, solr.abortOnConfigurationError, solr.directoryFactory, solr.clustering.enabled,
solr.velocity.enabled etc}}, but for some opts we fail to do so.
> Before release of 4.0 we should make sure to clean this up.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message