lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (JIRA)" <>
Subject [jira] [Updated] (SOLR-3313) Rename "Query Type" to "Request Handler" in SolrJ APIs
Date Thu, 14 Jun 2012 23:18:43 GMT


Hoss Man updated SOLR-3313:

    Component/s:     (was: web gui)
                 clients - java
        Summary: Rename "Query Type" to "Request Handler" in SolrJ APIs  (was: Rename "Query
Type" to "Request Handler" in API and UI )

The Admin UI was already updated to reflect this in another issue, so clarifying scope of
summary to be specific about SolrJ.

> Rename "Query Type" to "Request Handler" in SolrJ APIs
> ------------------------------------------------------
>                 Key: SOLR-3313
>                 URL:
>             Project: Solr
>          Issue Type: Improvement
>          Components: clients - java
>            Reporter: David Smiley
>             Fix For: 4.0
> Nobody should speak of "query types" any more; it's "request handlers".  I understand
we want to retain the "qt" parameter as such but I think we should change the names of it
wherever we can find it.  We can leave some older API methods in place as deprecated.
> As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message