lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Smiley (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-3313) Rename "Query Type" to "Request Handler" in SolrJ APIs
Date Wed, 20 Jun 2012 04:36:43 GMT

    [ https://issues.apache.org/jira/browse/SOLR-3313?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13397259#comment-13397259
] 

David Smiley commented on SOLR-3313:
------------------------------------

I committed SOLR-3313_Rename_Query_Type_to_Request_Handler.patch to trunk r1351932 and to
4x r1351933. 
                
> Rename "Query Type" to "Request Handler" in SolrJ APIs
> ------------------------------------------------------
>
>                 Key: SOLR-3313
>                 URL: https://issues.apache.org/jira/browse/SOLR-3313
>             Project: Solr
>          Issue Type: Improvement
>          Components: clients - java
>            Reporter: David Smiley
>            Assignee: David Smiley
>             Fix For: 4.0
>
>         Attachments: SOLR-3313_Rename_Query_Type_to_Request_Handler.patch
>
>
> Nobody should speak of "query types" any more; it's "request handlers".  I understand
we want to retain the "qt" parameter as such but I think we should change the names of it
wherever we can find it.  We can leave some older API methods in place as deprecated.
> As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message