lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Smiley (JIRA)" <>
Subject [jira] [Resolved] (SOLR-3313) Rename "Query Type" to "Request Handler" in SolrJ APIs
Date Fri, 22 Jun 2012 02:45:42 GMT


David Smiley resolved SOLR-3313.

    Resolution: Fixed

Committed to trunk in r1352760 and 4x in r1352761.  Closing.
> Rename "Query Type" to "Request Handler" in SolrJ APIs
> ------------------------------------------------------
>                 Key: SOLR-3313
>                 URL:
>             Project: Solr
>          Issue Type: Improvement
>          Components: clients - java
>            Reporter: David Smiley
>            Assignee: David Smiley
>             Fix For: 4.0
>         Attachments: SOLR-3313_Rename_Query_Type_to_Query_Parser.patch, SOLR-3313_Rename_Query_Type_to_Request_Handler.patch
> Nobody should speak of "query types" any more; it's "request handlers".  I understand
we want to retain the "qt" parameter as such but I think we should change the names of it
wherever we can find it.  We can leave some older API methods in place as deprecated.
> As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message