lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <>
Subject [jira] [Commented] (LUCENE-4101) Remove XXXField.TYPE_STORED
Date Sun, 10 Jun 2012 14:04:43 GMT


Robert Muir commented on LUCENE-4101:

yeah less words :)

but this matters much less to me if this issue is part of the alpha release.
the current patch is backwards compatible, it just adds ctors.

i know we only commit to the index format for alpha, but we shouldnt just break
things like .document package for naming reasons alone once we released it: i think
that would be really confusing. the .document package is used by EVERYONE.

so in my opinion (which i dont expect to be the consensus opinion, its just how I feel),
if we want NOT_STORED or whatever, we should rename it before alpha release.

> ---------------------------
>                 Key: LUCENE-4101
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Bug
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>            Priority: Blocker
>             Fix For: 4.0, 5.0
>         Attachments: LUCENE-4101.patch, LUCENE-4101.patch, LUCENE-4101.patch, LUCENE-4101.patch,
> Spinoff from LUCENE-3312.
> For 4.0 I think we should simplify the sugar field APIs by requiring
> that you add a StoredField if you want to store the field.  Expert users
> can still make a custom FieldType that both stores and indexes...

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message