Thanks, that solved it !

Perhaps this target should be run when I run 'ant clean' from the root? I wasn't aware that I should do such a thing, and I must say it's confusing :). Nothing in the error message suggested or even hint that.

Shai

On Wed, May 2, 2012 at 11:55 AM, Dawid Weiss <dawid.weiss@cs.put.poznan.pl> wrote:
Make sure you ant clean-jars -- I suspect there are two versions of
junit4 that reside in your classpath for some reason and an older
version is picked up before the new one.

The difference between jvms is I think explained by the order
attributes are reported by the XML parser -- both of these attributes
have been added in one version of junit4 so they're both unsupported
by an older JAR that is most likely in your classpath.

This issue should be fixed for the future either by checking that no
left-over jars are present (those not accompanied by .sha1 signatures)
or by building the classpath using ivy (which should simply point to
the current jar versions, ignoring anything else).

Dawid

On Tue, May 1, 2012 at 5:06 PM, Shai Erera <serera@gmail.com> wrote:
> Hi
>
> I svn up and ran 'ant test-core', but hit this strange error:
>
> lucene\build.xml:50: The following error occurred while executing this line:
> lucene\common-build.xml:1018: The following error occurred while executing
> this line:
> lucene\common-build.xml:744: report-text doesn't support the
> "useSimpleNames" attribute
>
> I have Ant 1.8.2.
>
> I tried to run the tests with an Oracle JVM (the above failure was from an
> IBM JVM), and hit this:
>
> lucene\build.xml:50: The following error occurred while executing this line:
> lucene\common-build.xml:1018: The following error occurred while executing
> this line:
> lucene\common-build.xml:744: report-text doesn't support the
> "maxClassNameColumns" attribute
>
> Each JVM complains about a different attribute !
>
> This is the Oracle Java 6 that I ran with:
>
> java version "1.6.0_31"
> Java(TM) SE Runtime Environment (build 1.6.0_31-b05)
> Java HotSpot(TM) 64-Bit Server VM (build 20.6-b01, mixed mode)
>
> Has anyone run into this?
>
> Shai

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org