lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shai Erera <ser...@gmail.com>
Subject Re: report-text doesn't support the "useSimpleNames" attribute
Date Wed, 02 May 2012 10:20:00 GMT
Thanks for the 'ant resolve' tip -- after I 'ant clean-jars' I ran 'ant
eclipse' just to be sure, but it didn't compile. The resolve thing resolved
it.

Something has happened recently ... these used to be much simpler. All I
needed to do is 'svn up; ant eclipse' and that's it. Now I seem to need to
run other commands as well ... I wish it was simpler as before.

Shai

On Wed, May 2, 2012 at 1:14 PM, Dawid Weiss <dawid.weiss@cs.put.poznan.pl>wrote:

> I was suggesting ant clean should incorporate clean-jars but it wasn't
> well received. I think Uwe complained it'd break IDEs (which it
> wouldn't -- you'd just need to run ant resolve afterwards).
>
> Alternatively, there should be a check for lose *.jar (without
> associated *.sha file).
>
> Dawid
>
> On Wed, May 2, 2012 at 11:55 AM, Shai Erera <serera@gmail.com> wrote:
> > Thanks, that solved it !
> >
> > Perhaps this target should be run when I run 'ant clean' from the root? I
> > wasn't aware that I should do such a thing, and I must say it's confusing
> > :). Nothing in the error message suggested or even hint that.
> >
> > Shai
> >
> > On Wed, May 2, 2012 at 11:55 AM, Dawid Weiss <
> dawid.weiss@cs.put.poznan.pl>
> > wrote:
> >>
> >> Make sure you ant clean-jars -- I suspect there are two versions of
> >> junit4 that reside in your classpath for some reason and an older
> >> version is picked up before the new one.
> >>
> >> The difference between jvms is I think explained by the order
> >> attributes are reported by the XML parser -- both of these attributes
> >> have been added in one version of junit4 so they're both unsupported
> >> by an older JAR that is most likely in your classpath.
> >>
> >> This issue should be fixed for the future either by checking that no
> >> left-over jars are present (those not accompanied by .sha1 signatures)
> >> or by building the classpath using ivy (which should simply point to
> >> the current jar versions, ignoring anything else).
> >>
> >> Dawid
> >>
> >> On Tue, May 1, 2012 at 5:06 PM, Shai Erera <serera@gmail.com> wrote:
> >> > Hi
> >> >
> >> > I svn up and ran 'ant test-core', but hit this strange error:
> >> >
> >> > lucene\build.xml:50: The following error occurred while executing this
> >> > line:
> >> > lucene\common-build.xml:1018: The following error occurred while
> >> > executing
> >> > this line:
> >> > lucene\common-build.xml:744: report-text doesn't support the
> >> > "useSimpleNames" attribute
> >> >
> >> > I have Ant 1.8.2.
> >> >
> >> > I tried to run the tests with an Oracle JVM (the above failure was
> from
> >> > an
> >> > IBM JVM), and hit this:
> >> >
> >> > lucene\build.xml:50: The following error occurred while executing this
> >> > line:
> >> > lucene\common-build.xml:1018: The following error occurred while
> >> > executing
> >> > this line:
> >> > lucene\common-build.xml:744: report-text doesn't support the
> >> > "maxClassNameColumns" attribute
> >> >
> >> > Each JVM complains about a different attribute !
> >> >
> >> > This is the Oracle Java 6 that I ran with:
> >> >
> >> > java version "1.6.0_31"
> >> > Java(TM) SE Runtime Environment (build 1.6.0_31-b05)
> >> > Java HotSpot(TM) 64-Bit Server VM (build 20.6-b01, mixed mode)
> >> >
> >> > Has anyone run into this?
> >> >
> >> > Shai
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> >> For additional commands, e-mail: dev-help@lucene.apache.org
> >>
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: dev-help@lucene.apache.org
>
>

Mime
View raw message