lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Male <gento...@gmail.com>
Subject Re: MISSING sha1 checksum file messages for two new jars
Date Wed, 16 May 2012 02:04:29 GMT
Hi Jack,

Sounds as though you've been bit by the unclear jar issue.  Basically
what's happened is that new versions of the testing jars have been released
and ivy has downloaded them.  However we don't currently have ivy setup to
clean out old jars so the jars of the older versions are still in your lib
folder.  However the license and checksum files have been updated (they're
kept in SVN), hence why you get the error.

Simplest way to tackle this at the moment is:

ant clean-jars resolve

Cheers
Chris

On Wed, May 16, 2012 at 12:51 PM, Jack Krupansky <jack@basetechnology.com>wrote:

>   My svn checkout from last week was building and testing fine, but when
> I did an svn checkout a little while ago I starting getting “MISSING sha1
> checksum file” messages for two jars that just got downloaded by ivy. The
> messages say “check the logs”, but I’m not sure what the logs would tell me
> in terms of some action I should take. I checked the build.xml and saw a
> target name="jar-checksums" description="Recompute SHA1 checksums for all
> JAR files.", so I ran that target successfully and now the two checksum
> messages are gone and the tests are running.
>
> So, either:
>
> 1. Could the message be changed to say “run ant jar-checksums” rather than
> “check the logs”, or
> 2. Could the jar checksum re-calculation be done automatically when new
> jars are downloaded?
>
> Or, is there some other action I should have taken when ant clean test
> produces these errors?
>
> Or, is this an indication of some other issue or step I should have taken
> between svn checkout and ant clean test?
>
> And let me know if this is an issue that I should file a Jira issue on, as
> opposed to something I was supposed to do myself in the build process.
>
> BTW, this is on Windows 7, cygwin bash.
>
> Here is the error output:
> --------
> [licenses] MISSING sha1 checksum file for:
> C:\cygwin\home\projects\lucene_trunk\lucene\test-framework\lib\junit4-ant-1.4.0.jar
> [licenses] MISSING sha1 checksum file for:
> C:\cygwin\home\projects\lucene_trunk\lucene\test-framework\lib\randomizedtesting-runner-1.4.0.jar
> [licenses] Scanned 20 JAR file(s) for licenses (in 2.00s.), 2 error(s).
>
> BUILD FAILED
> C:\cygwin\home\projects\lucene_trunk\build.xml:55: The following error
> occurred while executing this line:
> C:\cygwin\home\projects\lucene_trunk\lucene\build.xml:174: The following
> error occurred while executing this line:
> C:\cygwin\home\projects\lucene_trunk\lucene\tools\custom-tasks.xml:22:
> License check failed. Check the logs.
> -------------------
>
> And here is the output from when those jars were apparently downloaded:
> -----------------
> ivy-fail:
>
> ivy-configure:
> [ivy:configure] :: loading settings :: file =
> C:\cygwin\home\projects\lucene_trunk\lucene\ivy-settings.xml
>
> resolve:
> [ivy:retrieve] downloading
> http://repo1.maven.org/maven2/com/carrotsearch/randomizedtesting/junit4-ant/1.5.0/junit4-ant-1.5.0.jar...
> [ivy:retrieve] ......................... (911kB)
> [ivy:retrieve] .. (0kB)
> [ivy:retrieve]  [SUCCESSFUL ]
> com.carrotsearch.randomizedtesting#junit4-ant;1.5.0!junit4-ant.jar (1424ms)
> [ivy:retrieve] downloading
> http://repo1.maven.org/maven2/com/carrotsearch/randomizedtesting/randomizedtesting-runner/1.5.0/randomizedtesting-runner-1.5.0.jar...
> [ivy:retrieve] ..... (140kB)
> [ivy:retrieve] .. (0kB)
> [ivy:retrieve]  [SUCCESSFUL ]
> com.carrotsearch.randomizedtesting#randomizedtesting-runner;1.5.0!randomizedtesting-runner.jar
> (981ms)
>
> resolve:
>      [echo] Building analyzers-common...
> --------------
>
> -- Jack Krupansky
>



-- 
Chris Male | Software Developer | DutchWorks | www.dutchworks.nl

Mime
View raw message