lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Neil Hooey (JIRA)" <j...@apache.org>
Subject [jira] [Issue Comment Edited] (SOLR-3431) Make dist-war-excl-slf4j target available in the Maven repository
Date Wed, 02 May 2012 20:46:51 GMT

    [ https://issues.apache.org/jira/browse/SOLR-3431?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13266892#comment-13266892
] 

Neil Hooey edited comment on SOLR-3431 at 5/2/12 8:45 PM:
----------------------------------------------------------

I put this in my {{<dependencies>}} section:

{code}
        <dependency>
            <groupId>org.slf4j</groupId>
            <artifactId>slf4j-jdk14</artifactId>
            <version>1.6.4</version>
            <scope>runtime</scope>
        </dependency>
{code}

And this in my {{<plugins>}} section:

{code}
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-war-plugin</artifactId>
                <version>2.2</version>
                <configuration>
                    <overlays>
                        <overlay>
                            <groupId>org.slf4j</groupId>
                            <artifactId>slf4j-jdk14</artifactId>
                            <excludes>
                                <exclude>WEB-INF/lib/slf4j-jdk14-1.6.4.jar</exclude>
                            </excludes>
                        </overlay>
                    </overlays>
                </configuration>
            </plugin>
{code}

And I get this error:

{code}
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-war-plugin:2.2:war (default-war)
on project solr: overlay [ id org.slf4j:slf4j-jdk14] is not a dependency of the project. ->
[Help 1]
{code}

What specifically were you implying can be done to make this work?
                
      was (Author: nhooey):
    I put this in my {{<dependencies}} section:

{code}
        <dependency>
            <groupId>org.slf4j</groupId>
            <artifactId>slf4j-jdk14</artifactId>
            <version>1.6.4</version>
            <scope>runtime</scope>
        </dependency>
{code}

And this in my {{<plugins>}} section:

{code}
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-war-plugin</artifactId>
                <version>2.2</version>
                <configuration>
                    <overlays>
                        <overlay>
                            <groupId>org.slf4j</groupId>
                            <artifactId>slf4j-jdk14</artifactId>
                            <excludes>
                                <exclude>WEB-INF/lib/slf4j-jdk14-1.6.4.jar</exclude>
                            </excludes>
                        </overlay>
                    </overlays>
                </configuration>
            </plugin>
{code}

And I get this error:

{code}
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-war-plugin:2.2:war (default-war)
on project solr: overlay [ id org.slf4j:slf4j-jdk14] is not a dependency of the project. ->
[Help 1]
{code}

What specifically were you implying can be done to make this work?
                  
> Make dist-war-excl-slf4j target available in the Maven repository
> -----------------------------------------------------------------
>
>                 Key: SOLR-3431
>                 URL: https://issues.apache.org/jira/browse/SOLR-3431
>             Project: Solr
>          Issue Type: Improvement
>    Affects Versions: 4.0
>            Reporter: Neil Hooey
>            Priority: Minor
>              Labels: maven, slf4j
>
> Since SOLR-2487 was closed, a new build target {{dist-war-excl-slf4j}} was created for
the Ant build, but this war file isn't in Maven yet.
> Users who want to build a Solr war with Maven and without slf4j included have to expand
the war file and delete the {{WEB-INF/lib/slf4j-jdk14-1.6.4.jar}} file.
> With this target in Maven, expanding the war won't be necessary.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message