lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrzej Bialecki (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-4055) Refactor SegmentInfo / FieldInfo to make them extensible
Date Mon, 14 May 2012 02:25:48 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-4055?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13274412#comment-13274412
] 

Andrzej Bialecki  commented on LUCENE-4055:
-------------------------------------------

+1. Per commit information could be named CommitInfo (which it really is). I like SegmentMetadata
- if we left SegmentInfo as a name it would be confusing with its current functionality.

Introspection could return Map<String,Object> to avoid converting e.g. numeric values
back and forth.
                
> Refactor SegmentInfo / FieldInfo to make them extensible
> --------------------------------------------------------
>
>                 Key: LUCENE-4055
>                 URL: https://issues.apache.org/jira/browse/LUCENE-4055
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: core/codecs
>            Reporter: Andrzej Bialecki 
>            Assignee: Robert Muir
>             Fix For: 4.0
>
>
> After LUCENE-4050 is done the resulting SegmentInfo / FieldInfo classes should be made
abstract so that they can be extended by Codec-s.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message