lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Liu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-3433) binary field returns differently when do the distribute search
Date Fri, 25 May 2012 07:07:23 GMT

    [ https://issues.apache.org/jira/browse/SOLR-3433?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13283178#comment-13283178
] 

Alex Liu commented on SOLR-3433:
--------------------------------

Sami, I think SOLR-3035 fixed the issue for a single node. This ticket is only for multiple
node. To reproduce it, you can set up a three nodes cluster, and upload solrconfig.xml, schema.xml
with binary fields and some testing data, then you can search on any node.
                
> binary field returns differently when do the distribute search
> --------------------------------------------------------------
>
>                 Key: SOLR-3433
>                 URL: https://issues.apache.org/jira/browse/SOLR-3433
>             Project: Solr
>          Issue Type: Bug
>          Components: search
>    Affects Versions: 3.5, 3.6, 4.0
>         Environment: linux, amazon ec2
>            Reporter: Alex Liu
>
> When install multiple nodes (more than one node), the repeated searches through solr
returns binary data back differently each time.
> <lst name="responseHeader"><int name="status">0</int><int name="QTime">26</int><lst
name="params"><str name="q">text_col:woodman</str></lst></lst><result
name="response" numFound="1" start="0" maxScore="0.13258252"><doc><str name="binary_col">[B:[B@714fef9f</str>
> <lst name="responseHeader"><int name="status">0</int><int name="QTime">11</int><lst
name="params"><str name="q">text_col:woodman</str></lst></lst><result
name="response" numFound="1" start="0" maxScore="0.13258252"><doc><str name="binary_col">[B:[B@4be22114</str><
> check this link, some one report the same issue. http://grokbase.com/t/lucene/solr-user/11beyhmxjw/distributed-search-and-binary-fields-w-solr-3-4
> it works for a single node, but fails for multiple node. it's something related to distributed
search

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message