lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Muir <rcm...@gmail.com>
Subject Re: Ant version for building Solr
Date Mon, 23 Apr 2012 17:33:44 GMT
On Mon, Apr 23, 2012 at 1:29 PM, Dawid Weiss
<dawid.weiss@cs.put.poznan.pl> wrote:

> Definitely not the early ones because they were buggy. 1.8.3 seems
> relatively fresh (February 29th, 2012), so I'd say 1.8.2 (2010-12-20)?
> This is a long delay from 1.8.2 to 1.8.3... just peeked at the rel.
> notes and there are issues that could affect us:
>
> https://issues.apache.org/bugzilla/show_bug.cgi?id=48789
>
> I also don't object to just saying 1.8.3 is the minimum required
> version. It's the trunk after all -- it'll be a month or two (ehm)
> before it is released so 1.8.3 will be a de-facto standard?
>

Well, for whatever version we require, i actually think if there were
serious bugs in 1.8.x, we should consider enforcing that we actually
have that minimal version (ant exposes a property for that). I think
its better to say 'you have the wrong version of ant, its not gonna
work' than to give a strange permgen/oom/wrong
packaging/miscompile/... of course if the bugs only affect some
special thing (particularly an undocumented task like a hudson one),
then maybe we don't need to go that far.



-- 
lucidimagination.com

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message