lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Muir <rcm...@gmail.com>
Subject Re: Ant version for building Solr
Date Mon, 23 Apr 2012 15:19:22 GMT
On Mon, Apr 23, 2012 at 10:37 AM, Smiley, David W. <dsmiley@mitre.org> wrote:
> I understand your point Rob.  But given your point of view, wouldn't it be sufficient
for the README to simply say "download Ant 1.7 and…" without explicitly telling the user
*not* to use Ant 1.8, which is suggestive of a particular problem with the newer version?
 You didn't tell them *not* to use Ant 1.9 yet either ;-) or… etc.  It goes without saying
when I read any instructions that references a particular version that that particular version
works, and that there is no guarantee of anything else.
>

I think what i meant is users usually see a required version and think
its a >= relationship. So when users try newer versions of junit (and
all their tests failed), or things don't work quite right in ant, then
they think the whole project is broken.

> Is there anything preventing Ant 1.8 being the release we advise people to use?  After
all, Ant 1.8 was already on my Mac after I had grabbed dev tools extras; I'm not sure when
I last explicitly installed it.

Yes: the fact we don't test it.

>
> JUnit and any other library is a non-issue since the build refers to particular versions.
>

I don't think its a non-issue, several times on the lists people tried
to use newer junit versions with test-framework and didn't understand
why things didnt work.

-- 
lucidimagination.com

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message