lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Iulius Curt (Created) (JIRA)" <>
Subject [jira] [Created] (LUCENE-3970) Rename getUnique[Field/Terms]Count() into size()
Date Mon, 09 Apr 2012 10:35:19 GMT
Rename getUnique[Field/Terms]Count() into size()

                 Key: LUCENE-3970
             Project: Lucene - Java
          Issue Type: Task
          Components: core/index
            Reporter: Iulius Curt
            Priority: Minor

Like Robert Muir said in LUCENE-3109:
{quote}Also I think there are other improvements we can do here that would be more natural:
Fields.getUniqueFieldCount() -> Fields.size()
Terms.getUniqueTermCount() -> Terms.size(){quote}
I believe this dramatically improves understandability (way less 'scary', actually beautiful).

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message