lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven A Rowe <sar...@syr.edu>
Subject RE: Problem running all of a module's tests under IntelliJ: "Wrong test finished."
Date Tue, 17 Apr 2012 22:00:05 GMT
Dawid,

I have included in the IntelliJ IDEA configuration for Lucene/Solr a set of "run configurations",
one per module, that runs all tests in each module.

After you have run "ant idea" at the top level, then opened the project in IntelliJ IDEA,
then set up the JDK to use (the menu path to set up the JDK is printed to the terminal after
you run "ant idea") you should be able to see something similar to this:

http://postimage.org/image/ivi5srd5v

To the left of the triangular green arrow icon (which means: run the selected run configuration),
there is a dropdown menu for run configurations.  In the above-linked image, I've left-clicked
on this dropdown, and the mouse is hovering over "Module analyzers-common" - this is one of
the modules that exhibits the test running problem.

Left-click on "Module analyzers-common" to set the active run configuration.  After you do
this, the run configuration dropdown will change to display this label.  Then you can start
the tests associated with this by clicking on the green triangular button to the right of
the run configuration dropdown.

When IntelliJ runs tests, it will first make the associated module and its dependent modules,
then show a JUnit pane at the bottom of the window, with a tree of test suites and their tests
on the left, and console output on the right.

Let me know if you need more info.

Steve

-----Original Message-----
From: dawid.weiss@gmail.com [mailto:dawid.weiss@gmail.com] On Behalf Of Dawid Weiss
Sent: Tuesday, April 17, 2012 5:26 PM
To: dev@lucene.apache.org
Subject: Re: Problem running all of a module's tests under IntelliJ: "Wrong test finished."

Steven can you send me a screenshot or something showing where I should click to get this
failure? :)

Dawid

On Tue, Apr 17, 2012 at 6:04 PM, Steven A Rowe <sarowe@syr.edu> wrote:
> Hi Dawid :)
>
> Do you use IntelliJ?  There appears to be some form of bad interaction between the new
RandomizedTesting library additions and IntelliJ's test runner.
>
> When I try to run all of an IntelliJ module's tests under IntelliJ, e.g. analyzers-common
or lucene (including core and test-framework), not all tests run; those that don't run are
reported as "not started".  The external test process reports "Wrong test finished." (???)
and then returns exit code -1.
>
> This behavior is relatively new - I don't think the modules/*->lucene/ move is the
culprit (the IntelliJ lucene+test-framework module didn't move and it has this issue).
>
> Here's the output from running all analyzers-common tests:
>
> ----------
> "C:\Program Files\Java\jdk1.6.0_21\bin\java" -ea -DtempDir=temp 
> -Didea.launcher.port=7541 "-Didea.launcher.bin.path=C:\Program Files 
> (x86)\JetBrains\IntelliJ IDEA 11.1\bin" -Dfile.encoding=UTF-8 
> -classpath "C:\Program Files (x86)\JetBrains\IntelliJ IDEA 
> 11.1\lib\idea_rt.jar;C:\Program Files (x86)\JetBrains\IntelliJ IDEA 
> 11.1\plugins\junit\lib\junit-rt.jar;C:\Program 
> Files\Java\jdk1.6.0_21\jre\lib\alt-rt.jar;C:\Program 
> Files\Java\jdk1.6.0_21\jre\lib\charsets.jar;C:\Program 
> Files\Java\jdk1.6.0_21\jre\lib\deploy.jar;C:\Program 
> Files\Java\jdk1.6.0_21\jre\lib\javaws.jar;C:\Program 
> Files\Java\jdk1.6.0_21\jre\lib\jce.jar;C:\Program 
> Files\Java\jdk1.6.0_21\jre\lib\jsse.jar;C:\Program 
> Files\Java\jdk1.6.0_21\jre\lib\management-agent.jar;C:\Program 
> Files\Java\jdk1.6.0_21\jre\lib\plugin.jar;C:\Program 
> Files\Java\jdk1.6.0_21\jre\lib\resources.jar;C:\Program 
> Files\Java\jdk1.6.0_21\jre\lib\rt.jar;C:\Program 
> Files\Java\jdk1.6.0_21\jre\lib\ext\dnsns.jar;C:\Program 
> Files\Java\jdk1.6.0_21\jre\lib\ext\localedata.jar;C:\Program 
> Files\Java\jdk1.6.0_21\jre\lib\ext\sunjce_provider.jar;C:\svn\lucene\d
> ev\trunk\lucene\build\analysis\analyzers-common\classes\test;C:\svn\lu
> cene\dev\trunk\lucene\build\analysis\analyzers-common\classes\java;C:\
> svn\lucene\dev\trunk\lucene\test-framework\lib\junit-4.10.jar;C:\svn\l
> ucene\dev\trunk\lucene\test-framework\lib\randomizedtesting-runner-1.2
> .0.jar;C:\svn\lucene\dev\trunk\lucene\build\lucene-idea\classes\test;C
> :\svn\lucene\dev\trunk\lucene\build\lucene-idea\classes\java;C:\svn\lu
> cene\dev\trunk\lucene\test-framework\lib\ant-1.7.1.jar;C:\svn\lucene\d
> ev\trunk\lucene\test-framework\lib\ant-junit-1.7.1.jar" 
> com.intellij.rt.execution.application.AppMain 
> com.intellij.rt.execution.junit.JUnitStarter -ideVersion5 
> @C:\Users\sarowe\AppData\Local\Temp\idea_junit3377604973713774012.tmp 
> -socket53790
>
> Test '.<default package>.WordBreakTestUnicode_6_0_0' ignored Test 
> 'org.apache.lucene.analysis.pattern.TestPatternReplaceCharFilter.testN
> astyPattern' ignored
>
> Wrong test finished. Last started: [] stopped: 
> testNastyPattern(org.apache.lucene.analysis.pattern.TestPatternReplace
> CharFilter); class org.junit.runner.Description
>
> Process finished with exit code -1
> ----------
>
>
> Steve
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org For 
> additional commands, e-mail: dev-help@lucene.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org For additional commands, e-mail:
dev-help@lucene.apache.org

Mime
View raw message