lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dawid Weiss (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-4016) Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to ant 1.8.x as the "officially supported" build platform.
Date Tue, 24 Apr 2012 20:48:09 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-4016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13260996#comment-13260996
] 

Dawid Weiss commented on LUCENE-4016:
-------------------------------------

I only see "package-info.class" generated for source files like spatial\src\java\org\apache\lucene\spatial\package-info.java.
This is generated with Ant 1.8 but is not with Ant 1.7.

There are no other differences other than timestamps (builds executed at different time).
                
> Check if all the packaging/ development tasks work with latest Ant 1.8.x and switch to
ant 1.8.x as the "officially supported" build platform.
> ----------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-4016
>                 URL: https://issues.apache.org/jira/browse/LUCENE-4016
>             Project: Lucene - Java
>          Issue Type: Task
>          Components: general/build
>            Reporter: Dawid Weiss
>            Assignee: Dawid Weiss
>            Priority: Trivial
>             Fix For: 4.0
>
>
> Diff the outputs between ant 1.8.2 and ant 1.7.1.
> {noformat}
> Target         Windows   Ubuntu    Mac   Jenkins
> ------------------------------------------------
> /
>   ivy-bootstrap  OK         ?       ?       ?
>   jar-checksums  OK         ?       ?       ?
>   validate       OK         ?       ?       ?
>   test           OK         ?       ?       ?
> lucene/
>   clover          ?         ?       ?       ?
>   documentation   ?         ?       ?       ?
>   javadocs        ?         ?       ?       ?
>   package-tgz     ?         ?       ?       ?
>   package-zip     ?         ?       ?       ?
>   package-tgz-src ?         ?       ?       ?
>   package-all-b*  ?         ?       ?       ?
> solr/
>   clover          ?         ?       ?       ?
>   create-package  ?         ?       ?       ?
>   dist            ?         ?       ?       ?
>   example         ?         ?       ?       ?
>   javadocs        ?         ?       ?       ?
>   package-src-tgz ?         ?       ?       ?
>   run-example     ?         ?       ?       ?
> {noformat}
> Check consistency with release instructions: http://wiki.apache.org/lucene-java/ReleaseTodo
and http://wiki.apache.org/solr/HowToRelease
> Differences log:
> - ant 1.8.x creates empty package-info.class where ant 1.7.x would fail to do so. This
is documented at http://ant.apache.org/manual/Tasks/javac.html and is the expected behavior.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message