lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-3109) Rename FieldsConsumer to InvertedFieldsConsumer
Date Sun, 08 Apr 2012 13:58:17 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-3109?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13249551#comment-13249551
] 

Robert Muir commented on LUCENE-3109:
-------------------------------------

Also I think there are other improvements we can do here that would be more natural:
* Fields.getUniqueFieldCount() -> Fields.size()
* Terms.getUniqueTermCount() -> Terms.size()

In general the names of the other statistics could probably use some help.
When i gave a lucene talk on the new stats i had to add "wtf are these things in english"
beside the name of each new stat. I can't suggest good java names at this time,
but these are the english names:

* Terms.getDocCount() -> "number of documents with value"
* Terms.getSumDocFreq() -> "number of postings"
* Terms.getSumTotalTermFreq() -> "number of tokens"

TermsEnum.totalTermFreq is probably ok, but maybe it was named that way
only to be consistent with docFreq? Really something like "number of occurrences"
is what most people would expect here.

                
> Rename FieldsConsumer to InvertedFieldsConsumer
> -----------------------------------------------
>
>                 Key: LUCENE-3109
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3109
>             Project: Lucene - Java
>          Issue Type: Task
>          Components: core/codecs
>    Affects Versions: 4.0
>            Reporter: Simon Willnauer
>            Assignee: Michael McCandless
>            Priority: Minor
>             Fix For: 4.0
>
>         Attachments: LUCENE-3109.patch, LUCENE-3109.patch, LUCENE-3109.patch, LUCENE-3109.patch,
LUCENE-3109.patch, LUCENE-3109.patch
>
>
> The name FieldsConsumer is missleading here it really is an InvertedFieldsConsumer and
since we are extending codecs to consume non-inverted Fields we should be clear here. Same
applies to Fields.java as well as FieldsProducer.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message