lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Iulius Curt (Updated) (JIRA)" <>
Subject [jira] [Updated] (LUCENE-3109) Rename FieldsConsumer to InvertedFieldsConsumer
Date Sun, 08 Apr 2012 12:48:18 GMT


Iulius Curt updated LUCENE-3109:

    Attachment: LUCENE-3109.patch

bq. Should we change AtomicReader to have invertedField() instead fields()? 

I worked out all the {{fields()}} methods that returned {{InvertedFields}}.
Also {{MIGRATE.txt}}

bq. Also the name FieldsEnum is now inconsistent.

This is not included in the patch because I have some difficulty deciding whether or not also
rename all the classes derived from {{FieldsEnum}} (like {{FilterAtomicReader.FilterFieldsEnum}})

Also, should {{MultiFields}} and {{MultiFieldsEnum}} get renamed?
> Rename FieldsConsumer to InvertedFieldsConsumer
> -----------------------------------------------
>                 Key: LUCENE-3109
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Task
>          Components: core/codecs
>    Affects Versions: 4.0
>            Reporter: Simon Willnauer
>            Assignee: Michael McCandless
>            Priority: Minor
>             Fix For: 4.0
>         Attachments: LUCENE-3109.patch, LUCENE-3109.patch, LUCENE-3109.patch, LUCENE-3109.patch,
LUCENE-3109.patch, LUCENE-3109.patch
> The name FieldsConsumer is missleading here it really is an InvertedFieldsConsumer and
since we are extending codecs to consume non-inverted Fields we should be clear here. Same
applies to as well as FieldsProducer.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message