lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Smiley (Created) (JIRA)" <>
Subject [jira] [Created] (SOLR-3313) Rename "Query Type" to "Request Handler" in API and UI
Date Tue, 03 Apr 2012 21:52:27 GMT
Rename "Query Type" to "Request Handler" in API and UI 

                 Key: SOLR-3313
             Project: Solr
          Issue Type: Improvement
            Reporter: David Smiley
             Fix For: 4.0

Nobody should speak of "query types" any more; it's "request handlers".  I understand we want
to retain the "qt" parameter as such but I think we should change the names of it wherever
we can find it.  We can leave some older API methods in place as deprecated.

As an example, in SolrJ I have to call solrQuery.setQueryType("/blah") instead of setRequestHandler()

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message