lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-3038) Solrj should use javabin wireformat by default with updaterequests
Date Fri, 20 Apr 2012 17:58:40 GMT

    [ https://issues.apache.org/jira/browse/SOLR-3038?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13258421#comment-13258421
] 

Uwe Schindler commented on SOLR-3038:
-------------------------------------

Ryan, Robert and me are talking about 2 different things in response to the comment:

{quote}
bq. 4.x cannot read any indexes older than 3.x

with XML, it it can read pre 3.x – the compatibility problem is with javabin
{quote}

Solr 4 cannot read a Solr 1.4 index (this means you install Solr 1.4, index some documents,
then upgrade this installation to 4.0 -> this will not work, try it out).

The way you are proposing are two different servers. And I see no reason to make the Solr
4 client talk to Solr 1.4 instances, sorry. But this is not an upgrade scenario. If you want
to upgrade from 1.4 you have to go through 3.x and once you have done this, all your clients
can be upgraded, too. And then in a second step you can upgrade to 4.0, and your clients,
too.

Like with any other software, client API libraries may not work with ancient server versions.
                
> Solrj should use javabin wireformat by default with updaterequests
> ------------------------------------------------------------------
>
>                 Key: SOLR-3038
>                 URL: https://issues.apache.org/jira/browse/SOLR-3038
>             Project: Solr
>          Issue Type: Improvement
>          Components: clients - java
>    Affects Versions: 4.0
>            Reporter: Sami Siren
>            Priority: Minor
>
> The javabin wire format is faster than xml when feeding Solr - it should become the default.


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message