lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3109) Rename FieldsConsumer to InvertedFieldsConsumer
Date Sun, 08 Apr 2012 10:36:18 GMT


Michael McCandless commented on LUCENE-3109:

bq. We need to change CHANGES.txt and MIGRATE.txt to the new API, it's now heavily outdated.

Thanks Uwe, you're right, my bad.

bq. Should we change AtomicReader to have invertedField() instead fields()? 


bq. Also the name FieldsEnum is now inconsistent.

I think it should be InvertedFieldsEnum?

Iulius do you want to make these changes?  Or I can... let me know.
> Rename FieldsConsumer to InvertedFieldsConsumer
> -----------------------------------------------
>                 Key: LUCENE-3109
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Task
>          Components: core/codecs
>    Affects Versions: 4.0
>            Reporter: Simon Willnauer
>            Assignee: Michael McCandless
>            Priority: Minor
>             Fix For: 4.0
>         Attachments: LUCENE-3109.patch, LUCENE-3109.patch, LUCENE-3109.patch, LUCENE-3109.patch,
> The name FieldsConsumer is missleading here it really is an InvertedFieldsConsumer and
since we are extending codecs to consume non-inverted Fields we should be clear here. Same
applies to as well as FieldsProducer.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message