lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Uwe Schindler <...@thetaphi.de>
Subject Re: Java 1.6 EOL
Date Fri, 16 Mar 2012 14:14:08 GMT
I see no problem in supporting Java 7. All tests run with Java 7, both 3.x and trunk. I have
a production instance of Lucene running with Java 7. The only requirement is u1.

Lucene 3.5 was the first version not only compiling against Java 7 worked, but also running
all tests. The code already makes use of reflection detected Java 7 code when reporting supressed
Exceptions.
--
Uwe Schindler
H.-H.-Meier-Allee 63, 28213 Bremen
http://www.thetaphi.de



Erick Erickson <erickerickson@gmail.com> schrieb:

Which just begs the question (sorry if it has been discussed before) of
whether we should officially only support Solr/Lucene 4.0 under Java 1.7.

Erick

On Fri, Mar 16, 2012 at 4:04 AM, Dawid Weiss <dawid.weiss@gmail.com> wrote:
> So close!
>
> https://blogs.oracle.com/henrik/entry/updated_java_6_eol_date?msgid=3-6077692575
>
> Dawid
>
>_____________________________________________

> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: dev-help@lucene.apache.org
>

_____________________________________________

To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message