lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yonik Seeley <>
Subject Re: Java 1.6 EOL
Date Fri, 16 Mar 2012 14:22:35 GMT
On Fri, Mar 16, 2012 at 9:49 AM, Erick Erickson <> wrote:
> Which just begs the question (sorry if it has been discussed before) of
> whether we should officially only support Solr/Lucene 4.0 under Java 1.7.

Lucene's purpose is to be a dependency for other projects, and that
would force all those projects to require Java7 also.  Seems like that
should wait.

Solr is a different matter, and has historically moved to new Java
versions earlier.  But it feels a bit early there too... unless the
features in Java7 outweigh the potential pain to people when we
require it.
>From a practical development point of view, it would be nice to have
4.x and 5.0 on the same Java version to minimize backporting pain.

-Yonik - Lucene/Solr Open Source Search Conference.
Boston May 7-10

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message