lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (Updated) (JIRA)" <>
Subject [jira] [Updated] (LUCENE-3930) nuke jars from source tree and use ivy
Date Thu, 29 Mar 2012 19:56:22 GMT


Hoss Man updated LUCENE-3930:

    Attachment: LUCENE-3930__ivy_bootstrap_target.patch

If the mountain won't come to us, we should at least make it easier for users to get to the

attached patch fails with a helpful message if the ivy tasks can't be loaded from the ant
classpath, and adds a new bootstrap target users can run to have us install ivy into ~/.ant/lib
for them if they want

I'm sure a lot of improvements could be made to the wording of the helpful message .. it's
probably got some typos in it.

hossman@bester:~/lucene/branch_lucene3930$ ant compile
Buildfile: build.xml







     [echo]      This build requires Ivy and Ivy could not be found in your ant classpath
     [echo]      (Due to classpath issues and the recursive nature of the Lucene/Solr 
     [echo]      build system, a local copy of Ivy can not be used an loaded dynamicaly 
     [echo]      by the build.xml)
     [echo]      You can either manually install a copy of Ivy 2.2.0 in your ant classpath:
     [echo]      Or this build file can do it for you by running the Ivy Bootstrap target:
     [echo]        ant ivy-bootstrap     
     [echo]      Either way you will only have to install Ivy one time.
     [echo]      'ant ivy-bootstrap' will install a copy of Ivy into your Ant User Library:
     [echo]        /home/hossman/.ant/lib
     [echo]      If you would prefer, you can have it installed into an alternative 
     [echo]      directory using the "-Divy_install_path=/some/path/you/choose" option, 
     [echo]      but you will have to specify this path every time you build Lucene/Solr 
     [echo]      in the future...
     [echo]        ant ivy-bootstrap -Divy_install_path=/some/path/you/choose
     [echo]        ...
     [echo]        ant -lib /some/path/you/choose clean compile
     [echo]        ...
     [echo]        ant -lib /some/path/you/choose clean compile


/home/hossman/lucene/branch_lucene3930/build.xml:52: The following error occurred while executing
this line:
/home/hossman/lucene/branch_lucene3930/lucene/common-build.xml:561: The following error occurred
while executing this line:
/home/hossman/lucene/branch_lucene3930/lucene/common-build.xml:289: Ivy is not available

Total time: 1 second

> nuke jars from source tree and use ivy
> --------------------------------------
>                 Key: LUCENE-3930
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Task
>          Components: general/build
>            Reporter: Robert Muir
>            Assignee: Robert Muir
>            Priority: Blocker
>             Fix For: 3.6
>         Attachments: LUCENE-3930-solr-example.patch, LUCENE-3930-solr-example.patch,
LUCENE-3930.patch, LUCENE-3930.patch, LUCENE-3930.patch, LUCENE-3930__ivy_bootstrap_target.patch,
ant_-verbose_clean_test.out.txt, noggit-commons-csv.patch, patch-jetty-build.patch
> As mentioned on the ML thread: "switch jars to ivy mechanism?".

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message