lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martijn van Groningen (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3778) Create a grouping convenience class
Date Wed, 07 Mar 2012 22:10:59 GMT


Martijn van Groningen commented on LUCENE-3778:

So, yeah, I think default to Sort.RELEVANCE is good? Maybe we have 1
search method doing that and another taking the GroupSort?

I think it's strange to have a default for the top N groups (10)? I
think app should have to specify that as an arg to search...
Makes sense.

bq. I think GroupingSearch (current name) is OK?
In the join module we have the JoinUtil. Maybe rename it to GroupUtil? Just to be consistent?
Or rename JoinUtil to JoinSearch?
> Create a grouping convenience class
> -----------------------------------
>                 Key: LUCENE-3778
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: modules/grouping
>            Reporter: Martijn van Groningen
>         Attachments: LUCENE-3778.patch, LUCENE-3778.patch
> Currently the grouping module has many collector classes with a lot of different options
per class. I think it would be a good idea to have a GroupUtil (Or another name?) convenience
class. I think this could be a builder, because of the many options (sort,sortWithinGroup,groupOffset,groupCount
and more) and implementations (term/dv/function) grouping has.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message