lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan McKinley (Commented) (JIRA)" <>
Subject [jira] [Commented] (SOLR-3159) Upgrade to Jetty 8
Date Wed, 07 Mar 2012 21:02:57 GMT


Ryan McKinley commented on SOLR-3159:

committed to trunk in #1298108

What are thoughts on porting to 3.x?  I am -0 for a few reasons:
 * 3.6 is hopefully soon -- I would like to see this test for a while
 * JSP complications
 ** requires JDK (not just JRE)
 ** the start.jar would need to be run with:
java -jar start.jar -OPTIONS=jsp

- - - -

Shawn, to run this with any .war file you can put the .war file in webapps

The pile of config files in etc are for the various features you can enable -- this just includes
the ones I think we need 
> Upgrade to Jetty 8
> ------------------
>                 Key: SOLR-3159
>                 URL:
>             Project: Solr
>          Issue Type: Task
>            Reporter: Ryan McKinley
>            Priority: Minor
>             Fix For: 4.0
> Solr is currently tested (and bundled) with a patched jetty-6 version.  
> Ideally we can release and test with a standard version.
> Jetty-6 (at codehaus) is just maintenance now.  New development and improvements are
now hosted at eclipse.  Assuming performance is equivalent, I think we should switch to Jetty

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message