lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Rowe (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-3260) Improve exception handling / logging for ScriptTransformer.init()
Date Tue, 20 Mar 2012 22:01:39 GMT

    [ https://issues.apache.org/jira/browse/SOLR-3260?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13233851#comment-13233851
] 

Steven Rowe commented on SOLR-3260:
-----------------------------------

Hi James,

The branch_3x Maven Jenkins job is now failing in {{TestScriptTransformer}} as a result of
your commit from this issue, e.g. https://builds.apache.org/job/Lucene-Solr-Maven-3.x/432/testReport/.

I'd like to expand the set of exception message checked in the JUnit assumptions that allow
tests to be skipped to include the two new messages your changes on this issue introduced:

Currently:

{noformat}
} catch (DataImportHandlerException e) {
  assumeFalse("JRE does not contain a JavaScript engine (OpenJDK)", e.getMessage().startsWith("<script>
can be used only in java 6 or above"));
  throw e;
}
{noformat}

Expanded:

{noformat}
} catch (DataImportHandlerException e) {
  assumeFalse("JRE does not contain a JavaScript engine (OpenJDK)", 
              e.getMessage().startsWith("<script> can be used only in java 6 or above")
              || e.getMessage().startsWith("Cannot load Script Engine for language:")
              || e.getMessage().startsWith("'eval' failed with language:"));
  throw e;
}
{noformat}

What do you think?
                
> Improve exception handling / logging for ScriptTransformer.init()
> -----------------------------------------------------------------
>
>                 Key: SOLR-3260
>                 URL: https://issues.apache.org/jira/browse/SOLR-3260
>             Project: Solr
>          Issue Type: Bug
>          Components: contrib - DataImportHandler
>    Affects Versions: 3.5, 4.0
>            Reporter: James Dyer
>            Assignee: James Dyer
>            Priority: Trivial
>             Fix For: 3.6, 4.0
>
>         Attachments: SOLR-3260.patch
>
>
> This came up on the user-list.  ScriptTransformer logs the same "need a >=1.6 jre"
message for several problems, making debugging difficult for users.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message