lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Uwe Schindler <...@thetaphi.de>
Subject Re: Java 1.6 EOL
Date Fri, 16 Mar 2012 14:28:08 GMT
Sorry, I misunderstood the original question...

-1 to *only* support Java 7 in both Lucene and Solr. This is way to early.

Java 7 is not yet released to the public end user, you can only get it as "developer" resource,
not on official end-user java download triggered e.g. from the browser on missing plugin.

Uwe
--
Uwe Schindler
H.-H.-Meier-Allee 63, 28213 Bremen
http://www.thetaphi.de



Yonik Seeley <yonik@lucidimagination.com> schrieb:

On Fri, Mar 16, 2012 at 9:49 AM, Erick Erickson <erickerickson@gmail.com> wrote:
> Which just begs the question (sorry if it has been discussed before) of
> whether we should officially only support Solr/Lucene 4.0 under Java 1.7.

Lucene's purpose is to be a dependency for other projects, and that
would force all those projects to require Java7 also. Seems like that
should wait.

Solr is a different matter, and has historically moved to new Java
versions earlier. But it feels a bit early there too... unless the
features in Java7 outweigh the potential pain to people when we
require it.
>From a practical development point of view, it would be nice to have
4.x and 5.0 on the same Java version to minimize backporting pain.

-Yonik
lucenerevolution.com - Lucene/Solr Open Source Search Conference.
Boston May 7-10

_____________________________________________

To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message