lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-3778) Create a grouping convenience class
Date Thu, 08 Mar 2012 11:26:58 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-3778?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13225146#comment-13225146
] 

Michael McCandless commented on LUCENE-3778:
--------------------------------------------

bq. In the join module we have the JoinUtil. Maybe rename it to GroupUtil? Just to be consistent?
Or rename JoinUtil to JoinSearch?

Hmm, except in JoinUtil's case, it just has one static method... vs GroupingSearch which you
instantiate, tweak, and use.  So I think it's good that they are named differently?
                
> Create a grouping convenience class
> -----------------------------------
>
>                 Key: LUCENE-3778
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3778
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: modules/grouping
>            Reporter: Martijn van Groningen
>         Attachments: LUCENE-3778.patch, LUCENE-3778.patch
>
>
> Currently the grouping module has many collector classes with a lot of different options
per class. I think it would be a good idea to have a GroupUtil (Or another name?) convenience
class. I think this could be a builder, because of the many options (sort,sortWithinGroup,groupOffset,groupCount
and more) and implementations (term/dv/function) grouping has.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message