lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Rowe (Issue Comment Edited) (JIRA)" <j...@apache.org>
Subject [jira] [Issue Comment Edited] (SOLR-3204) solr-commons-csv must not use the org.apache.commons.csv package
Date Wed, 07 Mar 2012 17:24:58 GMT

    [ https://issues.apache.org/jira/browse/SOLR-3204?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13224515#comment-13224515
] 

Steven Rowe edited comment on SOLR-3204 at 3/7/12 5:23 PM:
-----------------------------------------------------------

bq. Steven Rowe: What other modified JARs do we have that are republished through maven?

For branch_3x:

||module||jar||
|Lucene benchmark|{{lucene/contrib/benchmark/lib/xercesImpl-2.9.1-patched-XERCESJ\-1257.jar}}|
|Solr clustering|{{solr/contrib/clustering/carrot2-core-3.5.0.jar}}|
|Solr langid|{{solr/contrib/langid/lib/jsonic-1.2.0.jar}}|
|Solr langid|{{solr/contrib/langid/lib/langdetect-r111-java5.jar}}|
|Solr core|{{solr/lib/apache-solr-noggit-r1099557.jar}}|
|Solr core|{{solr/lib/commons-csv-1.0-SNAPSHOT-r966014.jar}}|

Trunk is the same, except that the carrot2-core jar is no longer required (it's required on
branch_3x because it's a specially Java5-compiled jar, but no longer on trunk/4.0, which requires
Java 6, and so can use the Maven central artifact.)



                
      was (Author: steve_rowe):
    bq. Steven Rowe: What other modified JARs do we have that are republished through maven?

For branch_3x:

||module||jar||
|Lucene benchmark|{{lucene/contrib/benchmark/lib/xercesImpl-2.9.1-patched-XERCESJ-1257.jar}}|
|Solr clustering|{{solr/contrib/clustering/carrot2-core-3.5.0.jar}}|
|Solr langid|{{solr/contrib/langid/lib/jsonic-1.2.0.jar}}|
|Solr langid|{{solr/contrib/langid/lib/langdetect-r111-java5.jar}}|
|Solr core|{{solr/lib/apache-solr-noggit-r1099557.jar}}|
|Solr core|{{solr/lib/commons-csv-1.0-SNAPSHOT-r966014.jar}}|

Trunk is the same, except that the carrot2-core jar is no longer required (it's required on
branch_3x because it's a specially Java5-compiled jar, but no longer on trunk/4.0, which requires
Java 6, and so can use the Maven central artifact.)



                  
> solr-commons-csv must not use the org.apache.commons.csv package
> ----------------------------------------------------------------
>
>                 Key: SOLR-3204
>                 URL: https://issues.apache.org/jira/browse/SOLR-3204
>             Project: Solr
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 3.5
>            Reporter: Emmanuel Bourg
>            Priority: Blocker
>             Fix For: 3.6
>
>         Attachments: SOLR-3204.patch, SOLR-3204.patch, SOLR-3204.patch, apache-solr-commons-csv-1.0-SNAPSHOT-r966014.jar,
rule.txt, rule.txt, solr-csv.patch
>
>
> The solr-commons-csv artifact reused the code from the Apache Commons CSV project but
the package wasn't changed to something else than org.apache.commons.csv in the process. This
creates a compatibility issue as the Apache Commons team works toward an official release
of Commons CSV. It prevents Commons CSV from using its own org.apache.commons.csv package,
or forces the renaming of all the classes to avoid a classpath conflict.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message