lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler" <...@thetaphi.de>
Subject RE: svn commit: r1301300 - in /lucene/dev/trunk/dev-tools/maven: pom.xml.template solr/core/pom.xml.template
Date Fri, 16 Mar 2012 06:30:22 GMT
Hi Ryan,

I already mentioned that in the issue: Should we not also place the "generic servlet API 2.5"
in the lib folder, so compilation of Solr does also check, that the Servlet(Filter)s are compatible
with the 2.5 version of the API, so also not-yet-3.0 Servlet container are supported. If we
compile against the 3.0 servlet api, it might happen that we call a method/use a class that
is not in 2.5, which would make the webapp fail on still not ancient Tomcats/JBoss/... installations.

Means a compile-time dependency also in ANT, but for testing we use the full Jetty from example
folder?

Uwe

-----
Uwe Schindler
H.-H.-Meier-Allee 63, D-28213 Bremen
http://www.thetaphi.de
eMail: uwe@thetaphi.de


> -----Original Message-----
> From: ryan@apache.org [mailto:ryan@apache.org]
> Sent: Friday, March 16, 2012 1:56 AM
> To: commits@lucene.apache.org
> Subject: svn commit: r1301300 - in /lucene/dev/trunk/dev-tools/maven:
> pom.xml.template solr/core/pom.xml.template
> 
> Author: ryan
> Date: Fri Mar 16 00:55:43 2012
> New Revision: 1301300
> 
> URL: http://svn.apache.org/viewvc?rev=1301300&view=rev
> Log:
> SOLR-3159: pom should only depend on the servlet API, not container specific
> version
> 
> Modified:
>     lucene/dev/trunk/dev-tools/maven/pom.xml.template
>     lucene/dev/trunk/dev-tools/maven/solr/core/pom.xml.template
> 
> Modified: lucene/dev/trunk/dev-tools/maven/pom.xml.template
> URL: http://svn.apache.org/viewvc/lucene/dev/trunk/dev-
> tools/maven/pom.xml.template?rev=1301300&r1=1301299&r2=1301300&view
> =diff
> ================================================================
> ==============
> --- lucene/dev/trunk/dev-tools/maven/pom.xml.template (original)
> +++ lucene/dev/trunk/dev-tools/maven/pom.xml.template Fri Mar 16 00:55:43
> 2012
> @@ -339,10 +339,10 @@
>          <artifactId>slf4j-simple</artifactId>
>          <version>${slf4j.version}</version>
>        </dependency>
> -      <dependency>
> -        <groupId>org.eclipse.jetty.orbit</groupId>
> -        <artifactId>javax.servlet</artifactId>
> -        <version>3.0.0.v201112011016</version>
> +      <dependency>
> +        <groupId>javax.servlet</groupId>
> +        <artifactId>servlet-api</artifactId>
> +        <version>2.5</version>
>        </dependency>
>        <dependency>
>          <groupId>com.spatial4j</groupId>
> 
> Modified: lucene/dev/trunk/dev-tools/maven/solr/core/pom.xml.template
> URL: http://svn.apache.org/viewvc/lucene/dev/trunk/dev-
> tools/maven/solr/core/pom.xml.template?rev=1301300&r1=1301299&r2=1301
> 300&view=diff
> ================================================================
> ==============
> --- lucene/dev/trunk/dev-tools/maven/solr/core/pom.xml.template (original)
> +++ lucene/dev/trunk/dev-tools/maven/solr/core/pom.xml.template Fri Mar 16
> 00:55:43 2012
> @@ -198,8 +198,8 @@
>        </exclusions>
>      </dependency>
>      <dependency>
> -      <groupId>org.eclipse.jetty.orbit</groupId>
> -      <artifactId>javax.servlet</artifactId>
> +      <groupId>javax.servlet</groupId>
> +      <artifactId>servlet-api</artifactId>
>        <!-- compile scope; solr-core is a jar not a war -->
>      </dependency>
>      <dependency>



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message