lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-3736) ParallelReader is now atomic, rename to ParallelAtomicReader and also add a ParallelCompositeReader (that requires LogDocMergePolicy to have identical subreader structure)
Date Tue, 07 Feb 2012 15:42:59 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-3736?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13202478#comment-13202478
] 

Robert Muir commented on LUCENE-3736:
-------------------------------------

As i stated earlier on the issue, I agree technically with the builder here, for these reasons:
* its not like Document/Field where we worry about making tons of objects in indexing
* as far as immutable objects for IndexReader subclasses, thats a no-brainer from my perspective.
* we need lots of checks that the 'structure' is the same to support per-segment search.

So the only remaining issue is the style... yes I don't personally like chaining, but I gave
my
+1 to the patch, because I thought Uwe's argument was reasonable (its true its not enforced),
and because I don't think its worth arguing over for such an expert API (there are bigger
wins
when it comes to cleaning up our APIs).

Personally I am glad to Uwe for all this work, we wanted to fix these issues in ParallelReader

for a long time (LUCENE-2766). It needed a policeman to do this, for all the checks to be
correct,
and good javadocs explaining how to make the composite case work.

So maybe we should just open a separate issue for the style? I just feel we would lose so
much
if we went back to what we had before this change, I'd really prefer it not be backed out
for
that reason.




                
> ParallelReader is now atomic, rename to ParallelAtomicReader and also add a ParallelCompositeReader
(that requires LogDocMergePolicy to have identical subreader structure)
> ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-3736
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3736
>             Project: Lucene - Java
>          Issue Type: Sub-task
>          Components: core/index
>            Reporter: Uwe Schindler
>             Fix For: 4.0
>
>         Attachments: LUCENE-3733.patch, LUCENE-3736.patch, LUCENE-3736.patch, LUCENE-3736.patch
>
>
> The plan is:
> - Move all subreaders to ctor (builder-like API. First build reader-set, then call build)
> - Rename ParallelReader to ParallelAtomicReader
> - Add a ParallelCompositeReader with same builder API, but taking any CompositeReader-set
and checks them that they are aligned (docStarts identical). The subreaders are ParallelAtomicReaders.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message