lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Iulius Curt (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3109) Rename FieldsConsumer to InvertedFieldsConsumer
Date Thu, 16 Feb 2012 12:20:59 GMT


Iulius Curt commented on LUCENE-3109:

Is this still valid? (It looks like a good place for me to enter the community)

Should also the *FieldsReader/Writer classes that derive FieldsProducer/Consumer become *InvertedFieldsReader/Writer?
> Rename FieldsConsumer to InvertedFieldsConsumer
> -----------------------------------------------
>                 Key: LUCENE-3109
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Task
>          Components: core/codecs
>    Affects Versions: 4.0
>            Reporter: Simon Willnauer
>            Priority: Minor
>             Fix For: 4.0
> The name FieldsConsumer is missleading here it really is an InvertedFieldsConsumer and
since we are extending codecs to consume non-inverted Fields we should be clear here. Same
applies to as well as FieldsProducer.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message