lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Miller (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SOLR-3091) When running in SolrCloud mode, whether a instance is supposed to be part of the quorum or not, it tries to start a local Solr ZK server.
Date Fri, 03 Feb 2012 04:39:53 GMT

     [ https://issues.apache.org/jira/browse/SOLR-3091?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mark Miller updated SOLR-3091:
------------------------------

    Description: When a Solr instance that is not part of the quorum tries to start the Solr
Zk server, no zkRun is set, and if not using localhost for the host, the ZK server fails to
start as we cannot match it with any URL in the zkHost string. We shouldn't be trying to start
the Zk Server at all - some bug that snuck in and was not spotted earlier because it didn't
manifest in Solr not starting when using localhost addresses.  (was: we try to match based
on localhost by default - otherwise what zkRun is set to - if multiple hosts match, we go
to port - however for a solr instance not part of the ensemble)
    
> When running in SolrCloud mode, whether a instance is supposed to be part of the quorum
or not, it tries to start a local Solr ZK server.
> -----------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: SOLR-3091
>                 URL: https://issues.apache.org/jira/browse/SOLR-3091
>             Project: Solr
>          Issue Type: Bug
>            Reporter: Mark Miller
>            Assignee: Mark Miller
>             Fix For: 4.0
>
>         Attachments: SOLR-3091.patch
>
>
> When a Solr instance that is not part of the quorum tries to start the Solr Zk server,
no zkRun is set, and if not using localhost for the host, the ZK server fails to start as
we cannot match it with any URL in the zkHost string. We shouldn't be trying to start the
Zk Server at all - some bug that snuck in and was not spotted earlier because it didn't manifest
in Solr not starting when using localhost addresses.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message