lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-3736) ParallelReader is now atomic, rename to ParallelAtomicReader and also add a ParallelCompositeReader (that requires LogDocMergePolicy to have identical subreader structure)
Date Tue, 07 Feb 2012 17:00:59 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-3736?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13202529#comment-13202529
] 

Uwe Schindler commented on LUCENE-3736:
---------------------------------------

As a comment came up on IRC:

{quote}
[17:21]	mikemccand: well... we could also remove the builder
[17:22]	mikemccand: PR is expert
{quote}

IndexReaders are now unmodifiable and I was able to make numDocs, maxDocs,... all final, so
reverting the removal of ParallelReader.add() is not an option. I think Robert and I agree
here, the old code was too risky - we should fix all of Lucene 4's API to remove not immutable
classes where possible.

We can also move Parallel*Reader to contrib, its very special and seldom used :-) The test
in facet module is not really needed (I was about to remove it already).


                
> ParallelReader is now atomic, rename to ParallelAtomicReader and also add a ParallelCompositeReader
(that requires LogDocMergePolicy to have identical subreader structure)
> ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-3736
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3736
>             Project: Lucene - Java
>          Issue Type: Sub-task
>          Components: core/index
>            Reporter: Uwe Schindler
>             Fix For: 4.0
>
>         Attachments: LUCENE-3733.patch, LUCENE-3736.patch, LUCENE-3736.patch, LUCENE-3736.patch
>
>
> The plan is:
> - Move all subreaders to ctor (builder-like API. First build reader-set, then call build)
> - Rename ParallelReader to ParallelAtomicReader
> - Add a ParallelCompositeReader with same builder API, but taking any CompositeReader-set
and checks them that they are aligned (docStarts identical). The subreaders are ParallelAtomicReaders.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message