lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3622) separate IndexDocValues interface from implementation
Date Fri, 09 Dec 2011 16:45:40 GMT


Uwe Schindler commented on LUCENE-3622:

I agree with Robert and Simon, we should have simpliest name (DocValues). The function stuff
is in my opinion already named, wrong, I hate e.g. ValueSource, this name should die, die,
die - and this one creates confusion everywhere :-)
> separate IndexDocValues interface from implementation
> -----------------------------------------------------
>                 Key: LUCENE-3622
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Task
>            Reporter: Robert Muir
>         Attachments: LUCENE-3622.patch
> Currently the o.a.l.index.values contains both the abstract apis and Lucene40's current
> I think we should move the implementation underneath Lucene40Codec, leaving only the
abstract apis.
> For example, simpletext might have a different implementation, and we might make a int8
> underneath preflexcodec to support norms.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message