lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martijn van Groningen (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SOLR-2975) Solr test failure when running under Java 1.5
Date Fri, 16 Dec 2011 17:12:30 GMT

     [ https://issues.apache.org/jira/browse/SOLR-2975?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Martijn van Groningen updated SOLR-2975:
----------------------------------------

    Attachment: SOLR-2975.patch

Attached refactored version of test. I ran the test 10000 times on my machine with Java 1.5
and didn't have failures.

There was also a concurrency issue in the testMultiThread() method. The access to the rowList
variable wasn't synchronized. Also the ThreadPoolExecutor wasn't cleaned up. This resulted
in memory issues and thread issues (OS couldn't create threads) if the tests were run for
more then 2000 times.
                
> Solr test failure when running under Java 1.5
> ---------------------------------------------
>
>                 Key: SOLR-2975
>                 URL: https://issues.apache.org/jira/browse/SOLR-2975
>             Project: Solr
>          Issue Type: Test
>          Components: contrib - DataImportHandler
>    Affects Versions: 3.5, 3.6
>         Environment: Java 1.5 only. OS X
>            Reporter: Erick Erickson
>            Assignee: Erick Erickson
>            Priority: Minor
>             Fix For: 3.6, 4.0
>
>         Attachments: SOLR-2975.patch, SOLR-2975.patch
>
>
> ant test -Dtestcase=TestSolrEntityProcessorUnit fails when running under Java 1.5 because
of faulty assumptions in the test.
> From e-mail thread (Hossman):
> ...those lines are assuming that row.entrySet will return something that
> has a predictible iteration order, but row is a Map of unknown creation
> (returned by the entityProcessor) ... so unless the entityProcessor is
> explicitly defined as returning something like SortedMap (which isn't
> suggested anywhere in this test) the test is making a really bad
> assumption.
> From e-mail. (Steven Rowe)
> FYI, I see this same failure when I run the branch_3x tests with Java 1.5, but not 1.6.
> and
> Oh, and the reason Jenkins isn't seeing this failure is that it runs branch_3x tests
using Java 1.6, after first *compiling* with Java 1.5
> Even though we won't run Solr 4 under java 1.5, I'll change it there anyway since this
is a bad assumption in the test.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message