lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dafna Sheinwald (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-3552) TaxonomyReader/Writer and their Lucene* implementation
Date Wed, 02 Nov 2011 12:19:32 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-3552?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13142082#comment-13142082
] 

Dafna Sheinwald commented on LUCENE-3552:
-----------------------------------------

Hi Shai,
Yes, the old (already forgotten) DB implementation of taxonomy index, and the subsequent Lucene
implementation gave rise to the definition of TaxonomyReader/Writer interface. Currently,
indeed, and we are left with Lucene (Directory) implementation only. But I thought that as
the interface is already there, and we have some thoughts of yet another implementation of
taxonomy index (and hence TaxonomyReader/Writer), as part of the Lucene search index, which
may help to ease the burden of synch between these two indices, why not let the interface
live a bit longer before we remove it.   Regards, Dafna.
                
> TaxonomyReader/Writer and their Lucene* implementation
> ------------------------------------------------------
>
>                 Key: LUCENE-3552
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3552
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: modules/facet
>            Reporter: Shai Erera
>            Assignee: Shai Erera
>            Priority: Trivial
>             Fix For: 3.5, 4.0
>
>
> The facet module contains two interfaces TaxonomyWriter and TaxonomyReader, with two
implementations Lucene*. We've never actually implemented two TaxonomyWriters/Readers, so
I'm not sure if these interfaces are useful anymore. Therefore I'd like to propose that we
do either of the following:
> # Remove the interfaces and remove the Lucene part from the implementation classes (to
end up with TW/TR impls). Or,
> # Keep the interfaces, but rename the Lucene* impls to Directory*.
> Whatever we do, I'd like to make the impls/interfaces impl also TwoPhaseCommit.
> Any preferences?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message