lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-2803) NPE in FacetComponent
Date Tue, 15 Nov 2011 23:55:51 GMT

    [ https://issues.apache.org/jira/browse/SOLR-2803?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13150908#comment-13150908
] 

Hoss Man commented on SOLR-2803:
--------------------------------

I'm more then a tad confused by this issue..

The first thing that jumps out at me is that the issue summary (and paths attached patch)
suggest that this problem was encountered against Solr 3.4, but the example URL is doing a
distrubuted query against multiple shards using date faceting -- distributed support for date
faceting didn't exist in Solr 3.4, and still doesn't exist anywhere on the 3x branch, it is
only on trunk (see SOLR-1709).  So I'm not really sure what the point of this example URL
is at all? even w/o the NPE it doesn't seem like it will do anything useful.

That lead me to suspect that perhaps there was a glitch in the 3x faceting code, where requesting
"facet=true" on a distributed query, w/o any facet fields might cause shards to return empty
facet results, which might lead to the NPE in question.  But when I did some adhoc testing
of this using Solr 3.4, I couldn't reproduce.  facet=true with no faceting, facet=true with
date faceting but only one shard has docs using that date field, etc... none of the situations
i could think of would cause this problem of the bitset not being initialized.

I then tried all of these sorts of adhoc testing again using trunk (where distributed date
faceting is supported) and i still couldn't reproduce the failure.

Fi: exactly which version of Solr are you using?  is it the same on every shard? if it is
a 3x version what exactly is the behavior you are expecting/getting with the date faceting
(even after your work-around patch) .. w/o this patch did you get the failure consistently?
can you post the details of what requests get logged on each of your shards when executing
one of these queries that fails and what those individual shards return when you execute those
logged queries against them manually?





                
> NPE in FacetComponent
> ---------------------
>
>                 Key: SOLR-2803
>                 URL: https://issues.apache.org/jira/browse/SOLR-2803
>             Project: Solr
>          Issue Type: Bug
>    Affects Versions: 3.3, 3.4
>            Reporter: Fi
>              Labels: patch
>             Fix For: 3.4
>
>         Attachments: FacetComponent.patch
>
>   Original Estimate: 10m
>  Remaining Estimate: 10m
>
> On a call to my multicore setup (with 'activity' being one of my cores):
> /solr/activity/select/?q=*:*&fq=bucket:1000&fq=dma:%22Albuquerque%22&version=2.2&start=0&rows=0&facet=on&facet.date=time&facet.date.start=2011-02-01T04:00:00Z&facet.date.end=2011-06-11T00:00:00Z&facet.date.gap=%2B1HOUR&wt=json&qt=grid
> I get a NPE in the FacetComponent patch.
> SEVERE: java.lang.NullPointerException
>         at org.apache.solr.handler.component.FacetComponent.countFacets(FacetComponent.java:347)
>         at org.apache.solr.handler.component.FacetComponent.handleResponses(FacetComponent.java:257)
>         at org.apache.solr.handler.component.SearchHandler.handleRequestBody(SearchHandler.java:289)
>         at org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:129)
>         at org.apache.solr.core.SolrCore.execute(SolrCore.java:1368)
>         at org.apache.solr.servlet.SolrDispatchFilter.execute(SolrDispatchFilter.java:356)
>         at org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:252)
>         at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
>         at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
>         at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:224)
>         at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
>         at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:462)
>         at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:164)
>         at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:100)
>         at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:851)
>         at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
>         at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:405)
>         at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:278)
>         at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:515)
>         at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:300)
>         at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
>         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
>         at java.lang.Thread.run(Thread.java:619)
> With a 500 error response.
> Here is the qt=grid RequestHandler definition in the solrconfig.xml
>   <requestHandler name="grid" class="solr.SearchHandler">
>     <lst name="defaults">
>        <str name="echoParams">explicit</str>
>        <int name="rows">10</int>
>        <str name="shards">core-dev-01.example.com:8080/jiwire/activity,core-dev-02.example.com:8080/jiwire/activity,core-dev-03.example.com:8080/jiwire/activity,core-dev-01.example.com:8080/jiwire/activity,core-dev-01.example.com:8080/jiwire/activity2,core-dev-02.example.com:8080/jiwire/activity2,core-dev-03.example.com:8080/jiwire/activity2,core-dev-01.example.com:8080/jiwire/activity2,core-dev-01.example.com:8080/jiwire/activity3,core-dev-02.example.com:8080/jiwire/activity3,core-dev-03.example.com:8080/jiwire/activity3,core-dev-01.example.com:8080/jiwire/activity3,core-dev-01.example.com:8080/jiwire/activity4,core-dev-02.example.com:8080/jiwire/activity4,core-dev-03.example.com:8080/jiwire/activity4,core-dev-01.example.com:8080/jiwire/activity4</str>
>     </lst>
>   </requestHandler>

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message