lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Erera (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3564) rename IndexWriter.rollback to .rollbackAndClose
Date Wed, 09 Nov 2011 08:17:51 GMT


Shai Erera commented on LUCENE-3564:

Sorry, I was confused with the IfNeeded from LUCENE-3454. But I don't like 'IfChanged' too
:). I think that should be part of the javadocs.

Here's a proposal -- if we think our users find these names confusing, why don't we do a poll
on java-user and get people to vote on whether they find these names confusing? Because it
looks to me like it's a flavor thing - some of us prefer to read javadocs while others prefer
methods names that tell us what they do, without reading javadocs.

I don't find that openIfChanged saves me from reading the javadocs, because I still need to
read them in order to know what will be returned if the reader hasn't changed.
> rename IndexWriter.rollback to .rollbackAndClose
> ------------------------------------------------
>                 Key: LUCENE-3564
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 3.5, 4.0
> Spinoff from LUCENE-3454, where Shai noticed that rollback is trappy since it [unexpected]
closes the IW.
> I think we should rename it to rollbackAndClose.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message