lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Erera (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-3454) rename optimize to a less cool-sounding name
Date Tue, 08 Nov 2011 06:36:51 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-3454?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13146106#comment-13146106
] 

Shai Erera commented on LUCENE-3454:
------------------------------------

bq. Sure, but remember: 1) this is the exception case (not the rule)

I disagree ... I find myself more and more these days telling people to limit their merge
size because of performance issues, whether it's for optimize/maybeMerge. Therefore I don't
think it's the exception case, or will remain like that for long.

bq. I think forceMerge(int) does a pretty good job explaining what the MP is going to try
to do.

Is that a Javadoc statement? Because we could have just fixed optimize() javadocs without
adding API that sort of commits to something that may not happen.

How about naming it doMaintenance?

{code}
If we took this approach... I think IW would still need a "default MP"
that it uses to kick off natural merges over time? (Ie, after a new
segment is flushed).
{code}

Sure, we will provide the best MP for doing natural/regular merges which will be the default
of IWC.

I agree this route is bigger than just renaming optimize(), and I don't think that we need
to change the interaction between IW and MP. But let's handle that in a separate issue.
                
> rename optimize to a less cool-sounding name
> --------------------------------------------
>
>                 Key: LUCENE-3454
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3454
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 3.4, 4.0
>            Reporter: Robert Muir
>            Assignee: Michael McCandless
>         Attachments: LUCENE-3454.patch
>
>
> I think users see the name optimize and feel they must do this, because who wants a suboptimal
system? but this probably just results in wasted time and resources.
> maybe rename to collapseSegments or something?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message