lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3577) rename expungeDeletes
Date Tue, 15 Nov 2011 12:08:51 GMT


Robert Muir commented on LUCENE-3577:

Also I think this method could do with some javadocs cleanup:
from the javadocs it is practically begging you to call it if you
ever delete, but doesn't TieredMP already handle this well?
> rename expungeDeletes
> ---------------------
>                 Key: LUCENE-3577
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Task
>            Reporter: Robert Muir
> Similar to optimize(), expungeDeletes() has a misleading name.
> We already had problems with this on the user list because TieredMergePolicy
> didn't 'expunge' all their deletes.
> Also I think expunge is the wrong word, because expunge makes it seem
> like you just wrangle up the deletes and kick them out of the party and
> that it should be fast.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message