lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (Updated) (JIRA)" <>
Subject [jira] [Updated] (LUCENE-3454) rename optimize to a less cool-sounding name
Date Fri, 04 Nov 2011 00:35:32 GMT


Michael McCandless updated LUCENE-3454:

    Attachment: LUCENE-3454.patch


I picked the name 'mergeIfNeeded', and it requires you pass in the maxSegmentCount (so mergeIfNeeded(1)
== what optimize() does today).

All tests pass, including Solr, but Solr has tons of user-facing references still to "optimize"
that I'm not sure how to fix (I tried to remove all references to optimize in Lucene).

I put nocommits for tests that need to be renamed... I'll do that at the last second so patching
is easier.
> rename optimize to a less cool-sounding name
> --------------------------------------------
>                 Key: LUCENE-3454
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 3.4, 4.0
>            Reporter: Robert Muir
>            Assignee: Michael McCandless
>         Attachments: LUCENE-3454.patch
> I think users see the name optimize and feel they must do this, because who wants a suboptimal
system? but this probably just results in wasted time and resources.
> maybe rename to collapseSegments or something?

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message