lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yonik Seeley (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3454) rename optimize to a less cool-sounding name
Date Fri, 04 Nov 2011 01:37:32 GMT


Yonik Seeley commented on LUCENE-3454:

It's at least an order of magnitude more painful to change common external interfaces in Solr
than in Lucene (or any other type-safe library).  "optimize" has been with us a very long
time, and it should stay.  It should be both simple and effective enough to clarify the documentation
if needed.  Changing the name would cause far more collective confusion and pain than the
very small percent of people who might not understand when it's appropriate to call (and changing
the name won't help them understand when it is appropriate!).

On a side note: optimize still does just that - an index with fewer segments and deleted documents
is still more efficient to search.  We just need to make sure to document the downsides as
> rename optimize to a less cool-sounding name
> --------------------------------------------
>                 Key: LUCENE-3454
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 3.4, 4.0
>            Reporter: Robert Muir
>            Assignee: Michael McCandless
>         Attachments: LUCENE-3454.patch
> I think users see the name optimize and feel they must do this, because who wants a suboptimal
system? but this probably just results in wasted time and resources.
> maybe rename to collapseSegments or something?

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message