lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Erera (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-3564) rename IndexWriter.rollback to .rollbackAndClose
Date Sun, 06 Nov 2011 19:09:51 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-3564?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13145081#comment-13145081
] 

Shai Erera commented on LUCENE-3564:
------------------------------------

Oh no, what have I done !? :)

I too agree we should not rename rollback to rollbackAndClose. And I second Yonik's question
- why do we have to close when we rollback?

I personally think that we're going overboard with these methods rename (including IR.openIfChanged
!), but if we're at "renaming methods with unexpected outcome", how about renaming addDocument
to addDocumentButIfYouHitOOMYouShouldClose? ;)
                
> rename IndexWriter.rollback to .rollbackAndClose
> ------------------------------------------------
>
>                 Key: LUCENE-3564
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3564
>             Project: Lucene - Java
>          Issue Type: Improvement
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 3.5, 4.0
>
>
> Spinoff from LUCENE-3454, where Shai noticed that rollback is trappy since it [unexpected]
closes the IW.
> I think we should rename it to rollbackAndClose.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message