lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3454) rename optimize to a less cool-sounding name
Date Fri, 04 Nov 2011 01:49:32 GMT


Robert Muir commented on LUCENE-3454:

Changing the name would cause far more collective confusion and pain than the very small percent
of people who might not understand when it's appropriate to call (and changing the name won't
help them understand when it is appropriate!).

And thats exactly my goal here: whatever it takes. I want to cause confusion so that people
think twice before calling optimize. Because I totally disagree with you that its a small
percentage of people that know when its appropriate to call, when integrations such as Jan's
example call it after every commit: thats horrible.

Thats why I think we should rename it in lucene, rename it in solr, but if people start pushing
back thats fine. 

I can totally take this up myself with the blogging/email list route instead and intentionally
cause so much fucking confusion that nobody will ever use this again.

> rename optimize to a less cool-sounding name
> --------------------------------------------
>                 Key: LUCENE-3454
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 3.4, 4.0
>            Reporter: Robert Muir
>            Assignee: Michael McCandless
>         Attachments: LUCENE-3454.patch
> I think users see the name optimize and feel they must do this, because who wants a suboptimal
system? but this probably just results in wasted time and resources.
> maybe rename to collapseSegments or something?

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message