lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Erera (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-3564) rename IndexWriter.rollback to .rollbackAndClose
Date Wed, 16 Nov 2011 08:26:51 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-3564?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13151083#comment-13151083
] 

Shai Erera commented on LUCENE-3564:
------------------------------------

Just a note: whatever we do here, we should also do to TwoPhaseCommit. This will happen automatically
since IW implements it, but I thought to point it out since the change to TPC will also affect
the facet's DirectoryTaxonmyWriter.

Also, let's not hold up this issue. Go on with the change.
                
> rename IndexWriter.rollback to .rollbackAndClose
> ------------------------------------------------
>
>                 Key: LUCENE-3564
>                 URL: https://issues.apache.org/jira/browse/LUCENE-3564
>             Project: Lucene - Java
>          Issue Type: Improvement
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 3.5, 4.0
>
>
> Spinoff from LUCENE-3454, where Shai noticed that rollback is trappy since it [unexpected]
closes the IW.
> I think we should rename it to rollbackAndClose.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message