lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (Updated) (JIRA)" <>
Subject [jira] [Updated] (LUCENE-3454) rename optimize to a less cool-sounding name
Date Thu, 10 Nov 2011 18:38:51 GMT


Michael McCandless updated LUCENE-3454:

    Attachment: LUCENE-3454.patch

OK, new patch with "forceMerge".  I think it's ready to commit!

I left the MergePolicy method separate (renamed to findForcedMerges);
I'm not sure we should merge it with the findMerges since that one
finds "natural" merges.  But we can explore on a new issue... this
patch is immense and "rote" renaming so I plan commit soon...

The patch should be applyable; I generated with "svn diff
--show-copies-as-adds" (svn 1.7).

> rename optimize to a less cool-sounding name
> --------------------------------------------
>                 Key: LUCENE-3454
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 3.4, 4.0
>            Reporter: Robert Muir
>            Assignee: Michael McCandless
>         Attachments: LUCENE-3454.patch, LUCENE-3454.patch
> I think users see the name optimize and feel they must do this, because who wants a suboptimal
system? but this probably just results in wasted time and resources.
> maybe rename to collapseSegments or something?

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message