lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (Commented) (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3454) rename optimize to a less cool-sounding name
Date Fri, 04 Nov 2011 01:21:32 GMT


Hoss Man commented on LUCENE-3454:

bq. I think its worth considering "optimize" command to throw an exception in Solr for this
reason... we can add an expert option like mergeIfNeeded instead?

I have mixed feelings on this ... Solr has really tried to ensure that the user level APIs
(ie: HTTP params and the xml syntax) are either unaffected by under the cover changes, or
provide good backcompat with warnings logged when people use "deprecated" syntax.

But I would suggest that we start by keeping this issue focused on nailing down the java level
issues in the "lucene" layer and get that committed.  Then when we're sure it's done and settled
and happy, create a new issue for tracking the solr level API changes, with considerations
 * should we log a deprecation warning to 3.x if <optimize> or param optimize=true is
specified, and ignore in 4.x?
 * should the existing 'maxSegments' attribute became an option on "commit" or add a new explicit
"merge" command?
 * what do we do with postOptimize events listener registrations? log a deprecation warning,
or rename and fire them if/when a merge to a single segment happens?

(my personal opinion, for any general change not just optimize, is to add new syntax to reflect
the new world order, but as long as we *can* support the old syntax we should -- with anoying
warning logs)
> rename optimize to a less cool-sounding name
> --------------------------------------------
>                 Key: LUCENE-3454
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 3.4, 4.0
>            Reporter: Robert Muir
>            Assignee: Michael McCandless
>         Attachments: LUCENE-3454.patch
> I think users see the name optimize and feel they must do this, because who wants a suboptimal
system? but this probably just results in wasted time and resources.
> maybe rename to collapseSegments or something?

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message